Minor slowdown in our app

Incident Report for Workfolio

Resolved

This incident has been resolved.
Posted Sep 14, 2023 - 12:44 UTC

Investigating

We are currently investigating this issue
Posted Sep 14, 2023 - 12:29 UTC
This incident affected: Desktop App.