Issue in accessing the desktop application
Incident Report for Workfolio
Resolved
This incident has been resolved.
Posted Apr 06, 2023 - 18:30 UTC
Investigating
Facing a minor slowdown issue in desktop app
Posted Apr 06, 2023 - 13:30 UTC
This incident affected: Website and Desktop App.