Minor slowdown causing the delay in data synchronisation
Incident Report for Workfolio
Resolved
This incident has been resolved
Posted Oct 05, 2023 - 11:50 UTC
Investigating
We are currently investigating this issue.
Posted Oct 05, 2023 - 10:21 UTC
This incident affected: Desktop App.