Desktop app responding slowly
Incident Report for Workfolio
Resolved
This incident has been resolved
Posted Aug 17, 2023 - 15:14 UTC
Update
We are continuing to investigate this issue.
Posted Aug 17, 2023 - 15:00 UTC
Update
We are continuing to investigate this issue.
Posted Aug 17, 2023 - 14:56 UTC
Update
We are continuing to investigate this issue.
Posted Aug 17, 2023 - 14:49 UTC
Investigating
We are currently investigating this issue
Posted Aug 17, 2023 - 13:42 UTC
This incident affected: Website and Desktop App.