Issue in Desktop App
Incident Report for Workfolio
Resolved
This incident has been resolved.
Posted Oct 01, 2021 - 20:15 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Oct 01, 2021 - 12:27 UTC
Investigating
We are currently working on this issue
Posted Sep 30, 2021 - 19:00 UTC
This incident affected: Desktop App.